La forma más fácil de detectar datos duplicados en Excel

Por ejemplo, hay datos como la imagen de abajo. La columna A contiene información sobre el nombre, que no debe contener datos duplicados o repetidos.

La forma más fácil de detectar datos duplicados

¿Cómo cambiar el color de la celda a rojo cuando hay datos repetidos?

Solución con formato condicional

Esta solución es la solución más simple.

Bloque de columnas A

Haga clic en Formato condicional – Resaltar reglas de celda – Valores duplicados.

La forma más fácil de detectar datos duplicados

Aparecerá un cuadro de diálogo como se muestra a continuación.

La forma más fácil de detectar datos duplicados

Luego haga clic en Aceptar. El resultado es como la imagen de abajo.

La forma más fácil de detectar datos duplicados

Todos los datos repetidos en la columna A son de color rojo.
Desafortunadamente, esta solución solo está disponible a partir de Excel 2007.

Solución con formato condicional y función COUNTIF

Si no tiene Excel 2007 o posterior, la solución es usar fórmulas de Excel.

Bloque de columnas A

Haga clic en Formato condicional y seleccione Nueva regla.

Aparecerá un cuadro de diálogo como se muestra a continuación.

La forma más fácil de detectar datos duplicados

Seleccione Usar una fórmula para determinar qué celda formatear.

(Si está utilizando Excel 2003, elija Formato, Formato condicional, en el primer cuadro combinado, elija «Fórmula es»)

Introduzca la siguiente fórmula:

=CONTAR.SI($A:$A,$A1)>1

Tenga en cuenta que los parámetros de criterios de la función CONTAR.SI utilizan referencias mixtas, lo que hace que las letras de las columnas sean referencias absolutas y los números de las filas sean referencias relativas.

Si hizo clic en Formato para especificar qué formato usar cuando el valor de la fórmula anterior se evalúe como VERDADERO.

Cuando hizo clic en el botón Aceptar.

El resultado es como la imagen de abajo.

La forma más fácil de detectar datos duplicados

Para datos repetidos, la celda se colorea de rojo.

Más artículos sobre estos consejos y trucos

  • Formato condicional
  • función CONTAR.SI
  • referencia de celda

¿ALGÚN COMENTARIO? #wpdevar_comment_1 intervalo,#wpdevar_comment_1 iframe{ancho:100% !importante;}

Leave a Reply